Our site will be unavailable for 4 hours starting on Friday, August 17th, 2018 from 11:00pm and ending at 3:00am CST on Saturday, August 18th for maintenance. We apologize for any inconvenience this may cause.

Kaplan University School of Professional and Continuing Education Kaplan University School of Professional and Continuing Education

System Requirements

Brightwood makes every attempt to make our websites and products mobile and tablet friendly. However, not all features are compatible with all tablets and phones.

Brightwood Real Estate Education Course TechSpecs:

  • When working on regulated course material, we recommend using a Windows- or Mac-based desktop or laptop computer.
  • We recommend the use of Windows 7-10 or macOS 10.9 or later operating systems.
  • We recommend the use of current Chrome, Firefox, or Safari browsers. We also support Internet Explorer 11 and Edge.
  • For business customers, please verify the browser choice and use with your manager or IT department.
  • We recommend online learners have the latest version of Flash (until Aug 1st 2018), when it will no longer be needed.
  • We recommend online learners have at least a 2MB connection.

Real Estate Accelerator Live Online TechSpecs:

Computers with operating system:

  • Windows 7—Windows 10
  • Mac OS X 10.9 (Mavericks)—10.12 (Sierra)

Mobile devices:

  • iOS 9 or later
    • Internet connection: 3G connection or better: Wi-Fi recommended for VoIP audio and video
    • minimum iPhone 4s
    • preferred minimum iPhone 5
    • minimum iPad 2
    • preferred minimum iPad Air
  • Recommended that iPad users download HTML5Meeting for best experience
  • Android 4.1 (Ice Cream Sandwich) or later
    • Internet connection: 3G connection or better: Wi-Fi recommended for VoIP audio and video

Bandwidth:

  • 500kbps per each video feed
  • 500kbps for screen sharing
  • Internet connection 1 Mbps or better: broadband recommended
    *Minimum requirements depend on the number of video feeds.

Recommended browsers:

  • Chrome, Firefox, Safari, and Edge will work without plug-ins
  • With plug-ins, Internet Explorer 11 will work